Please report new issues athttps://github.com/DOCGroup
> * Shouldn't the compression IDs be defined in the IDL as constants? > Having the user perform calls with "magic numbers" like > "manager->get_compressor(4)" seems ugly. I think it's clearer to > use symbolic constants like so > "manager->get_compressor(Compression::zlib)". OMG Codec formats are > defined in this manner, for example: > > module IOP { > ... > typedef short EncodingFormat; > const EncodingFormat ENCODING_CDR_ENCAPS = 0; > ... > struct Encoding { > EncodingFormat format; > octet major_version; > octet minor_version; > }; > ... > Codec create_codec (in Encoding enc) raises (UnknownEncoding); > ... > };
Tue Apr 24 12:06:12 UTC 2007 Johnny Willemsen <jwillemsen@remedy.nl> * tao/Compression/Compression.pidl: * tao/Compression/zlib/ZlibCompressor_Factory.cpp: * tests/Compression/server.cpp: Made the CompressorId an unsigned short and define constants for the predefined compressor ids. Thanks to Ossama for proposing this change. This fixed bugzilla bug 2910.
changed the compressorid to unsigned long,